]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - HLT/configure.ac
Corrections for the TGeo interface. (A. Gheata)
[u/mrichter/AliRoot.git] / HLT / configure.ac
index 5b935e91211848be4959b2a41fda128de2cd0fbd..22ace9d92eb27400c1545de5e200db463529fbc2 100644 (file)
@@ -191,8 +191,19 @@ if test ! "x$have_aliroot" = "xno" ; then
                                       have_alirawdata=$CHECKLIB], 
                                      [have_alirawdata=no])
        ]) dnl AC_CHECK_LIB RAWDatabase
-  AC_MSG_CHECKING(for AliRawReader classes in RAWData libraries)
-  AC_MSG_RESULT($have_alirawdata)
+  AC_MSG_CHECKING([for AliRawReader classes in RAWData libraries])
+  AC_MSG_RESULT([$have_alirawdata])
+
+  dnl
+  dnl check whether AliLog supports notification callback
+  dnl
+  have_alilog_notification=no
+  AC_MSG_CHECKING([whether AliLog supports notification callback])
+  AC_LINK_IFELSE([AC_LANG_PROGRAM([#include <AliLog.h>], 
+                                 [AliLog::AliLogNotification fct])],
+                                  [have_alilog_notification=yes], 
+                                 [AC_DEFINE(NO_ALILOG_NOTIFICATION)])
+  AC_MSG_RESULT([$have_alilog_notification])
 
   dnl
   dnl Check for the interface of AliExternalTrackParam which has been changed
@@ -474,16 +485,17 @@ AM_CONDITIONAL(EN_HLT_TRD, test x$enable_trd = xyes)
 AC_MSG_RESULT([$enable_trd])
 
 dnl ------------------------------------------------------------------
-AC_MSG_CHECKING([whether to enable HLT logging])
-AH_TEMPLATE([NOLOGGING],[disable hlt logging])
-AC_ARG_ENABLE(logging,
-  [AC_HELP_STRING([--enable-logging],
-      [enable logging])],
-  [],[enable_logging=yes])
-if test "x$enable_logging" != "xyes" ; then 
-  AC_DEFINE(NOLOGGING)
+AC_MSG_CHECKING([whether to disable AliRoot logging])
+AH_TEMPLATE([NOALIROOT_LOGGING],[disable AliRoot logging])
+AC_ARG_ENABLE(aliroot-logging,
+  [AC_HELP_STRING([--disable-aliroot-logging],
+      [disable logging through AliRoot logging methods])],
+  [],[enable_aliroot_logging=no])
+if test "x$enable_aliroot_logging" != "xno" ; then 
+  AC_DEFINE(NOALIROOT_LOGGING)
 fi
-AC_MSG_RESULT([$enable_logging])
+AM_CONDITIONAL(NOALIROOT_LOGGING, test x$enable_aliroot_logging != no)
+AC_MSG_RESULT([$enable_aliroot_logging])
 
 dnl ------------------------------------------------------------------
 AC_MSG_CHECKING([whether to enable saving MC data through the chain])
@@ -552,6 +564,7 @@ AC_CONFIG_FILES([Makefile
                 BASE/Makefile
                 BASE/setenv.sh
                 BASE/setenv.csh
+                BASE/util/Makefile
                 SampleLib/Makefile
                 TPCLib/Makefile
                 TPCLib/mapping2array.cxx