]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - ITS/CMakeLists.txt
Compilation with Root6
[u/mrichter/AliRoot.git] / ITS / CMakeLists.txt
index e0253ccaadf33f41a625007c60eaabd3a3fa2451..ea4b7ec1374e3c33a15780a73037d3ff0073d0e7 100644 (file)
@@ -1,29 +1,13 @@
-# -*- mode: cmake -*-
-# Create a library called "lib<name>" which includes the source files given in
-# the array .
-# The extension is already found.  Any number of sources could be listed here.
+# AliRoot Build System CMakeLists for ITS
+#
+# Author: Johny Jose m(johny.jose@cern.ch)
+#         Port of previous Makefile build to cmake
 
-set(INCLUDE_DIRECTORIES
-${CMAKE_SOURCE_DIR}/ITS
-${CMAKE_SOURCE_DIR}/STEER
-${CMAKE_SOURCE_DIR}/RAW
-${ROOT_INCLUDE_DIR}
-)
+cmake_minimum_required(VERSION 2.8.4 FATAL_ERROR)
 
-include_directories( ${INCLUDE_DIRECTORIES})
-
-set(LINK_DIRECTORIES
-${ROOT_LIBRARY_DIR}
-) 
-
-link_directories( ${LINK_DIRECTORIES})
-
-SetModule()
-
-include(CMake_libITSrec.txt)
-
-include(CMake_libITSbase.txt)
-
-include(CMake_libITSsim.txt)
+file(GLOB PACKAGES CMake*.pkg)
 
+ALICE_BuildModule()
+#
+ADD_SUBDIRECTORY(UPGRADE)