]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - JETAN/CMakeLists.txt
Move the non-implemented code to the private section
[u/mrichter/AliRoot.git] / JETAN / CMakeLists.txt
index e68000db1ebc88ed1cdacda94ffb63436d208e79..ed125b29f3d5bd508ac5231b858792ff617cf63f 100644 (file)
@@ -1,16 +1,25 @@
-# AliRoot Build System CMakeLists for JETAN
-#
-# Author: Johny Jose m(johny.jose@cern.ch)
-#         Port of previous Makefile build to cmake
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
 
-cmake_minimum_required(VERSION 2.8.8 FATAL_ERROR)
+add_subdirectory(JETAN)
+if(FASTJET_FOUND)
+    message(STATUS "FastJet found. Enabling FASTJETAN")
+    add_subdirectory(FASTJETAN)
+endif(FASTJET_FOUND)
 
-if(NOT FASTJET_FOUND)
-  set(PACKAGES CMakelibJETAN.pkg)
-  message(STATUS "skipping FASTJETAN")
-else()
-  set(PACKAGES CMakelibFASTJETAN.pkg CMakelibJETAN.pkg)
-endif(NOT FASTJET_FOUND)
+# Installing the macros
+install(DIRECTORY macros DESTINATION JETAN)
 
-
-ALICE_BuildModule()
+message(STATUS "JETAN enabled")