]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - MONITOR/CMakeLists.txt
Extra header added to the list
[u/mrichter/AliRoot.git] / MONITOR / CMakeLists.txt
index faaf3e2ea1f8826930c97d52af7f9ec7c7917ec4..35453cd98b215638e7731e2c51c8b71fce19dfd9 100644 (file)
@@ -1,30 +1,32 @@
-# AliRoot Build System CMakeLists for MONITOR
-#
-# Author: Johny Jose m(johny.jose@cern.ch)
-#         Port of previous Makefile build to cmake
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
 
-cmake_minimum_required(VERSION 2.8.8 FATAL_ERROR)
+# MONITOR libraries
+add_subdirectory(MONITOR)
 
-# This will only build MONITOR only if ZeroMQ is found
-
-set (PACKAGES
-  CMakelibMONITOR.pkg
-  alitestproc/CMakebinalitestproc.pkg
-  deroot/CMakebinderoot.pkg
-  monitorCheck/CMakebinmonitorCheck.pkg
-  monitorGDC/CMakebinmonitorGDC.pkg 
-)
+# MONITOR executables
+add_subdirectory(alitestproc)
+add_subdirectory(deroot)
+add_subdirectory(monitorCheck)
+add_subdirectory(monitorGDC)
 
 if(ZEROMQ_FOUND)
-set(PACKAGES "${PACKAGES}"
-  CMakelibMONITORzmq.pkg
-  alistoragemanager/CMakebinalistorage.pkg
-  alistoragemanager/CMakebinalistorageadmin.pkg
-  alistoragemanager/CMakebinalifakedisplay.pkg
-  alistoragemanager/CMakebinalistorageminimalexample.pkg
-  alistoragemanager/CMakebinalistoragegetpoints.pkg
-  alieventserver/CMakebinalieventserver.pkg
-)
-ENDIF(ZEROMQ_FOUND)
+    add_subdirectory(MONITORzmq)
+    add_subdirectory(alistoragemanager)
+    add_subdirectory(alionlinereco)
+endif(ZEROMQ_FOUND)
+
 
-ALICE_BuildModule()
+message(STATUS "MONITOR enabled")