]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - PHOS/PHOSbase/CMakeLists.txt
VZERO DAs + Object target dependencies
[u/mrichter/AliRoot.git] / PHOS / PHOSbase / CMakeLists.txt
index 0c7bf9904cb1361a0789d90b0879b296408fe54c..3f48e0928058da3ae9764e92deb5bf1ed95b5abc 100644 (file)
@@ -102,6 +102,8 @@ generate_rootmap("${MODULE}" "${LIBDEPS}" "${CMAKE_CURRENT_SOURCE_DIR}/${MODULE}
 # Create an object to be reused in case of static libraries 
 # Otherwise the sources will be compiled twice
 add_library(${MODULE}-object OBJECT ${SRCS} G__${MODULE}.cxx)
+# Follow headers dependencies
+add_dependencies(${MODULE}-object ${ALIROOT_DEPENDENCIES})
 # Add a library to the project using the object
 add_library(${MODULE} SHARED $<TARGET_OBJECTS:PHOSbase-object>)