]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - STAT/CMakeLists.txt
Fix compilation problems on Fedora (Laurent)
[u/mrichter/AliRoot.git] / STAT / CMakeLists.txt
index 6aecf03a0cc5e80bfd1e4b70519f78623654246b..c1ef924418cee786a4906e33ce825ddafaac25d9 100644 (file)
@@ -1,25 +1,10 @@
-# -*- mode: cmake -*-
+# AliRoot Build System CMakeLists for STAT
+#
+# Author: Johny Jose m(johny.jose@cern.ch)
+#         Port of previous Makefile build to cmake
 
-# Create a library called "lib<name>" which includes the source files given in
-# the array .
-# The extension is already found.  Any number of sources could be listed here.
-
-set(INCLUDE_DIRECTORIES
-${CMAKE_SOURCE_DIR}/STAT
-${CMAKE_SOURCE_DIR}/STEER 
-${ROOT_INCLUDE_DIR}
-)
-
-include_directories( ${INCLUDE_DIRECTORIES})
-
-set(LINK_DIRECTORIES
-${ROOT_LIBRARY_DIR}
-) 
-
-link_directories( ${LINK_DIRECTORIES})
-
-SetModule()
-
-include(CMake_libSTAT.txt)
+cmake_minimum_required(VERSION 2.8.4 FATAL_ERROR)
 
+file(GLOB PACKAGES CMake*.pkg)
 
+ALICE_BuildModule()