]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - STEER/CMakeLists.txt
Installing the content of data folder
[u/mrichter/AliRoot.git] / STEER / CMakeLists.txt
index bcbdc94ca36e4183fd4cba7e2dd2c4bc4d58a926..899efacaedd72595c789a26be4c9063e4b661302 100644 (file)
@@ -1,33 +1,26 @@
-# -*- mode: cmake -*-
-# Create all libraries of STEER subdirectory 
-
-set(INCLUDE_DIRECTORIES
-${CMAKE_SOURCE_DIR}/STEER
-${CMAKE_BINARY_DIR}/STEER
-${CMAKE_SOURCE_DIR}/RAW
-${CMAKE_SOURCE_DIR}/HLT/sim
-${ROOT_INCLUDE_DIR}
-)
-
-include_directories( ${INCLUDE_DIRECTORIES})
-
-set(LINK_DIRECTORIES
-${ROOT_LIBRARY_DIR}
-) 
-
-link_directories( ${LINK_DIRECTORIES})
-
-SetModule()
-
-# include files with the descriptions how to build the
-# different libraries of this subdirectory
-
-include(CMake_libESD.txt)
-
-include(CMake_libCDB.txt)
-
-include(CMake_libSTEERBase.txt)
-
-include(CMake_libSTEER.txt)
-
-include(CMake_libAOD.txt)
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
+
+# Include the libraries
+add_subdirectory (STEERBase)
+add_subdirectory (ESD)
+add_subdirectory (AOD)
+add_subdirectory (CDB)
+add_subdirectory (STEER)
+
+# Macros
+install(DIRECTORY macros DESTINATION STEER)
+
+message(STATUS "STEER enabled")