]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - STEER/CMakeLists.txt
Non-implemented method are commented out or moved to the private part of the class
[u/mrichter/AliRoot.git] / STEER / CMakeLists.txt
index cd1351f2e5384a1d6c4f611eaa65aa279c8110c0..899efacaedd72595c789a26be4c9063e4b661302 100644 (file)
@@ -1,10 +1,26 @@
-# AliRoot Build System CMakeLists for STEER
-#
-# Author: Johny Jose m(johny.jose@cern.ch)
-#         Port of previous Makefile build to cmake
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
 
-cmake_minimum_required(VERSION 2.8.8 FATAL_ERROR)
+# Include the libraries
+add_subdirectory (STEERBase)
+add_subdirectory (ESD)
+add_subdirectory (AOD)
+add_subdirectory (CDB)
+add_subdirectory (STEER)
 
-file(GLOB PACKAGES CMake*.pkg)
+# Macros
+install(DIRECTORY macros DESTINATION STEER)
 
-ALICE_BuildModule()
+message(STATUS "STEER enabled")