]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - STEER/STEERBase/CMakeLists.txt
CMake: same deps for linked libs and rootmaps
[u/mrichter/AliRoot.git] / STEER / STEERBase / CMakeLists.txt
index dc9ea838a6b20223d6e498f5a48bdbcdf14d9a5a..c7263738440de215fe6dacd1ad91fef5ab8eb3f4 100644 (file)
@@ -155,7 +155,7 @@ generate_rootmap("STEERBase" "${LIBDEPS}" "${CMAKE_CURRENT_SOURCE_DIR}/${MODULE}
 # Additional compilation flags for the object
 set_target_properties(${MODULE}-object PROPERTIES COMPILE_FLAGS "")
 # Linking the library, not the object
-target_link_libraries(${MODULE} Core EG Geom Gpad Graf3d Graf Hist MathCore Matrix Minuit Net Physics RIO Tree VMC)
+target_link_libraries(${MODULE} ${LIBDEPS})
 
 # Public include folders that will be propagated to the dependecies
 target_include_directories(${MODULE} PUBLIC ${incdirs})