]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - T0/CMakeLists.txt
Adding macros to create Calibration objects
[u/mrichter/AliRoot.git] / T0 / CMakeLists.txt
index 369864abcd6f7ec456514b6adb67ecf226298bce..c7f44f5c41ad1c04e107f9c815d7ae1439986b4a 100644 (file)
@@ -1,10 +1,29 @@
-# AliRoot Build System CMakeLists for T0
-#
-# Author: Johny Jose m(johny.jose@cern.ch)
-#         Port of previous Makefile build to cmake
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
 
-cmake_minimum_required(VERSION 2.8.8 FATAL_ERROR)
+add_subdirectory(T0base)
+add_subdirectory(T0calib)
+add_subdirectory(T0rec)
+add_subdirectory(T0sim)
+add_subdirectory(T0shuttle)
 
-file(GLOB PACKAGES CMake*.pkg)
+if(DA)
+    add_subdirectory(DA)
+endif(DA)
 
-ALICE_BuildModule()
+# Install macros
+install(FILES AddTaskT0Analysis.C DESTINATION T0)
+
+message(STATUS "T0 enabled")