]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - ZDC/CMakeLists.txt
Fix for FMD DA
[u/mrichter/AliRoot.git] / ZDC / CMakeLists.txt
index 8fb14ed78f66d692153f63da7400b02aa60bad44..484baae7792288b58738cc16eb3ec227fcdfbde9 100644 (file)
@@ -1,13 +1,45 @@
-# AliRoot Build System CMakeLists for ZDC
-#
-# Author: Johny Jose m(johny.jose@cern.ch)
-#         Port of previous Makefile build to cmake
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
 
-cmake_minimum_required(VERSION 2.8.4 FATAL_ERROR)
+add_subdirectory(ZDCbase)
+add_subdirectory(ZDCrec)
+add_subdirectory(ZDCsim)
 
-file(GLOB PACKAGES CMake*.pkg)
+if(DA)
+    add_subdirectory(DA)
+endif(DA)
 
-ALICE_BuildModule()
+install(FILES 
+  GlauberMCDist.root
+  GlauberMCHistos.root
+  PMTGainsdata.txt
+  SpectatorSignal.root
+  ZNASignal.root
+  ZNCSignal.root
+  ZNsignalntu.root
+  ZPASignal.root
+  ZPCSignal.root
+  ZPsignalntu.root
+  light22620362207s
+  light22620362208s
+  light22620362209s
+  light22620362210s
+  light22620552207s
+  light22620552208s
+  light22620552209s
+  light22620552210s
+  DESTINATION ZDC)
 
-install ( FILES "SpectatorSignal.root" "GlauberMCDist.root" 
-         DESTINATION ZDC )
+message(STATUS "ZDC enabled")