]> git.uio.no Git - u/mrichter/AliRoot.git/blobdiff - ZDC/CMakeLists.txt
Converting PYTHIA8 to native cmake
[u/mrichter/AliRoot.git] / ZDC / CMakeLists.txt
index 543021583481b7bef69303da00955d97856494a4..d3af8ed39ff01619c21ec94958debbfbcf5bf43f 100644 (file)
@@ -1,15 +1,23 @@
-# AliRoot Build System CMakeLists for ZDC
-#
-# Author: Johny Jose m(johny.jose@cern.ch)
-#         Port of previous Makefile build to cmake
+# **************************************************************************
+# * Copyright(c) 1998-2014, ALICE Experiment at CERN, All rights reserved. *
+# *                                                                        *
+# * Author: The ALICE Off-line Project.                                    *
+# * Contributors are mentioned in the code where appropriate.              *
+# *                                                                        *
+# * Permission to use, copy, modify and distribute this software and its   *
+# * documentation strictly for non-commercial purposes is hereby granted   *
+# * without fee, provided that the above copyright notice appears in all   *
+# * copies and that both the copyright notice and this permission notice   *
+# * appear in the supporting documentation. The authors make no claims     *
+# * about the suitability of this software for any purpose. It is          *
+# * provided "as is" without express or implied warranty.                  *
+# **************************************************************************
 
-cmake_minimum_required(VERSION 2.8.8 FATAL_ERROR)
+add_subdirectory(ZDCbase)
+add_subdirectory(ZDCrec)
+add_subdirectory(ZDCsim)
 
-file(GLOB PACKAGES CMake*.pkg)
-
-ALICE_BuildModule()
-
-install ( FILES 
+install(FILES 
   GlauberMCDist.root
   GlauberMCHistos.root
   PMTGainsdata.txt
@@ -20,4 +28,6 @@ install ( FILES
   ZPASignal.root
   ZPCSignal.root
   ZPsignalntu.root
-  DESTINATION ZDC )
+  DESTINATION ZDC)
+
+message(STATUS "ZDC enabled")